Mavericks | iii threetreeslight

February 10, 2014

[OS X Mavericks]chromeのscrollがいきなり効かなくなる

調べて見るとあるあるの模様。 chrome側も認識していて、issueも上がっているがOSサイドの問題みたい。 Issue 310649: OSX Maverick: Scrolling stops working when using the mouse gesture to switch to the previous page 暫定的な解決ほほうとしては、PRAMをクリアするとの事 Apple Support - NVRAM/PRAM をリセットする 参考 Mac OS X Mavericks Chromeでページスクロールができない不具合がある

October 28, 2013

osx 10.9 Mavericksでgit svnが動かない。

git svnが動かない。まずい。 どうやら、SVNへのパスが何処にも見つからない模様。 $ git svn rebase Can't locate SVN/Core.pm in @INC (@INC contains: /opt/boxen/homebrew/Cellar/git/1.8.2.3-boxen1/lib /Library/Perl/5.16/darwin-thread-multi-2level /Library/Perl/5.16 /Network/Library/Perl/5.16/darwin-thread-multi-2level /Network/Library/Perl/5.16 /Library/Perl/Updates/5.16.2 /System/Library/Perl/5.16/darwin-thread-multi-2level /System/Library/Perl/5.16 /System/Library/Perl/Extras/5.16/darwin-thread-multi-2level /System/Library/Perl/Extras/5.16 .) at /opt/boxen/homebrew/Cellar/git/1.8.2.3-boxen1/lib/Git/SVN/Utils.pm line 6. command line toolはいれており、SVNは存在する。 $ svn --version svn, version 1.7.10 (r1485443) compiled Aug 13 2013, 15:31:22 そうしたら、command line toolsで入れたSVNライブラリを、@INCの検索先であるライブラリのどこかへぶっ込む。 今回はperl 5.1.6の下へ入れます。 $ sudo ln -s /Applications/Xcode.app/Contents/Developer/Library/Perl/5.16/darwin-thread-multi-2level/SVN /System/Library/Perl/Extras/5.16/SVN すると、、、、 $ git svn rebase Can't locate loadable object for module SVN::_Core in @INC (@INC contains: /opt/boxen/homebrew/Cellar/git/1. ... Read more

October 27, 2013

osx 10.9 Mavericks でcommand line toolをインストールする

さてさて、早速mavericksにupgradeしてxcodeも5.1にしら、あれ、、、gitも何も動かない、、、 Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/include/ruby.h Gem files will remain installed in /opt/boxen/repo/.bundle/ruby/2.0.0/gems/json-1.8.0 for inspection. Results logged to /opt/boxen/repo/.bundle/ruby/2.0.0/gems/json-1.8.0/ext/json/ext/generator/gem_make.out もちろんcommand line tool周りだろうと思ってpropertyを見たら、、、 あれ、、、command line toolが無い、、、 調べると以下の通り。 command line tools for new 10.9 OSX for ruby gems? 必要になったタイミングでXcode上のtrigerが発動し、インストールするか問うpopupが出てくるっぽい。 なにそれ、、、どんな嫌がらせ、、、?無理、無理ゲー。耐えられない。 そんなときはterminalから必要に迫らせて、trigerを強制的に発動させる。 $ xcode-select --install やっと先に進めそうです。 boxenの設定直そう。